20 lines
438 B
Nix
20 lines
438 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
};
|
|
outputs = { self, nixpkgs }:
|
|
let
|
|
name = "simple";
|
|
system = "x86_64-linux";
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
src = ./.;
|
|
in
|
|
{
|
|
packages.${system}.default = derivation {
|
|
inherit name src system;
|
|
builder = with pkgs; "${bash}/bin/bash";
|
|
args = [ "-c" "echo foo > $out" ];
|
|
};
|
|
};
|
|
}
|