18 lines
361 B
Nix
18 lines
361 B
Nix
{
|
|
pkgs ? import <nixpkgs> {},
|
|
}:
|
|
let
|
|
manifests = pkgs.writeText "bla" ''
|
|
here be dragons
|
|
'';
|
|
in
|
|
pkgs.dockerTools.streamLayeredImage {
|
|
name = "blah";
|
|
includeStorePaths = false;
|
|
fakeRootCommands = ''
|
|
cp -Lr ${manifests} my-text-file
|
|
cat my-text-file
|
|
rm -fr nix
|
|
'';
|
|
}
|